Rated 1 out of 5 stars

@Kaliel
The reason it's not presented as compatible with FF3 is because apparently no work has been done on it for about 9 months now. I agree that it is free, but so are other FF add-ons and those that wish to preserve their functionality are updated regardless of their free status. I'm not bitchin' because this theme is not out, I'm saying that in today's world of frequent updates it is non-functional to most FF users in general. If updates were not important, all of us might as well be running IE3 or Netscape or some equally antiquated piece of software.