Rated 3 out of 5 stars

No support for Firefox 3.5? I really like this theme but I need support for version 3.5.