Rated 5 out of 5 stars

Even Easier Way To Make BlockSite Work With Firefox 3.5.2+

I have simply installed the "Nightly Tester Tools" add on, this allows you to download and force an install of older add ons not yet fully updated for the very latest version of Firefox by ignoring/blocking add on compatibility checks.

If you do this you need to be aware this may cause strange behaviours in Firefox, but I have not yet encountered any problems by forcibly installing 1 or 2 older add ons which have not been updated for Firefox 3.5.2+

This review is for a previous version of the add-on (0.7.1).