Rated 1 out of 5 stars

it sucks cause you can't use it with firefox 3.0.3