Rated 4 out of 5 stars

in the photo it look cool. but it dont seem to work with firefox 3.6 beta1.

This review is for a previous version of the add-on (1.3). 

support

Could you please send me what operating support system you are using. I currently have no problems installing it on 3.6 beta

Thanks