Needs an update Rated 1 out of 5 stars

It needs to be updated for the latest version of Firefox.