FF 7 and above fix Rated 5 out of 5 stars

Hi, for use with FF7 and above download the .xpi file, open with WinRAR, open install.rdf with Wordpad, edit "maxVersion" in Firefox section from 5.* to 8(or higher if you choose).*, open FF Add-Ons, install from file. For me it works on all my computers.

This review is for a previous version of the add-on (1.67).