waiting for FF 3.0 beta support Rated 4 out of 5 stars

This is one of my fav extensions.
Waiting for the new version which is compatible with FF 3 Beta.

This review is for a previous version of the add-on (0.2.5.6).