ff 3.6.2 ? Rated 4 out of 5 stars

Not work with FF 3.6.2 :-(