Rated 4 out of 5 stars

why all my favorite adds are not compatible with ff3?!! please update it, pleeeeeeeease

This review is for a previous version of the add-on (0.1.4).