Patch after FFv47 (no Fuel lib) Rated 4 out of 5 stars

Apply this patch to have the extension up and running again.

--- autotrans.js Mon Jun 27 11:33:19 2016
+++ autotrans.js Mon Jun 27 11:37:46 2016
@@ -38,0 +39 @@ var autotrans = {
- application: Components.classes["@mozilla.org/fuel/application;1"].getService(Components.interfaces.fuelIApplication),
@@ -51 +52 @@ var autotrans = {
- glennpow.debugging = autotrans.application.prefs.getValue("extensions.autotrans.debug", false);
+ glennpow.debugging = autotrans.prefService.getBoolPref("extensions.autotrans.debug");
@@ -162 +163 @@ var autotrans = {
- var maxAttempts = autotrans.application.prefs.getValue("extensions.autotrans.attempts", 3);
+ var maxAttempts = autotrans.prefService.getIntPref("extensions.autotrans.attempts");
@@ -187 +188 @@ var autotrans = {
- var maxTimeout = autotrans.application.prefs.getValue("extensions.autotrans.timeout", 10000);
+ var maxTimeout = autotrans.prefService.getIntPref("extensions.autotrans.timeout");
@@ -350 +351 @@ var autotrans = {
- var sendMetaInfo = autotrans.application.prefs.getValue("extensions.autotrans.metainfo", false);
+ var sendMetaInfo = autotrans.prefService.getBoolPref("extensions.autotrans.metainfo");

NOT WORKING Rated 1 out of 5 stars

Please help
aint working with waterfox 47.0
would really appreciate and rate it 5 stars

Unsupported in Firefox 47 Rated 3 out of 5 stars

Depends on the FUEL library removed in 47.

Rated 4 out of 5 stars

Hasn't the client had to send a X-session-id back to the server for the conversation to continue:
I get this back:
409: Conflict

Your request had an invalid session-id header.

To fix this, follow these steps:

1. When reading a response, get its X-Transmission-Session-Id header and remember it
2. Add the updated header to your outgoing requests
3. When you get this 409 error message, resend your request with the updated header

This requirement has been added to help prevent CSRF attacks.

X-Transmission-Session-Id: <long alpha-numeric string>

Wonder what I messed up w/on my setting...
sigh...
It used to work well!... so will rate it a 4 now...
(still works on 3.2.28 ...)

Original 3.0 is still working fine with Firefox 14 Rated 5 out of 5 stars

I'd say it's safe to bump maxversion to at least 14

Yeah, I'm gonna sort it along with the few things necessary to get it through full review. Should be soon, but I've got a million other side projects to be distracted by!