435 reviews for this add-on
  • Veery good
  • This add-on doesn't work with the latest versions of Firefox and most likely never will. I've spent ages trying to work with the replacement add-on (for e10s), but it just doesn't do the job for me. Now I've installed Waterfox, with which the old faithful Autofill Forms works just fine. Now I can run this add-on with Waterfox alongside the latest version of Firefox long into the future.
  • Does not work. Needs to be updated to the quality of the original of the same name as was promised by the creator. As this is a complete waste of space.
  • good
  • Please update it for new firefox. we need this tool.
  • Best add-ons for forms filling. No real competitors. Essential in my everyday practice. Only one reason why I not upgrade to Firefox >52 its FORM FILLER.
  • This a really good extension but it should support the new firefox quantum.
  • Not downloading this extention in mozila fire fox.
  • thanks
  • This is very helpful tool for SEO's
    Please update it for new firfox, its not working with new mozilla version
  • ok
  • this is very good tool
  • Don't work Quantum
  • what nice idea
  • does not work
  • Please update for Firefox 58 (Quantum)
  • There is problem that details in form changes to phone number or anything else.
  • nice
  • I used to like this form so much this worked for me the best than any other form fillers... it can fill anything.......... Please update it for quantum please please please pleasepleasepleasepleasepleaseplease
  • Used to work like a champ absolutely loved it. Will not work with Firefox. No one seems to be able to fix it. Bummer
  • Kindly Update Your Add-ons Not Working In Firefox 58.0
  • Nice
  • Bien
  • nice
  • Hey developer guys! I LOVED this. It was a little bit getting used to but after carefully reading your notes, and a few mistakes, I was filling forms perfectly in seconds! I could enter easily 10 contests in a minute - sometimes more. But when I went to a 64 bit computer I had to go with the less likeable upgraded version by only one of you. Now with Quantum, it is basically unusable. I would gladly make another contribution if you would update this add-on to work with Quantum. Whaddaya say? Please? Sincerely, many happy users.