Auto Shutdown NG Version History

22 versions

Be careful with old versions!

These versions are displayed for reference and testing purposes. You should always use the latest version of an add-on.

Version 0.9.16 45.6 KB Works with Firefox 26.0a1 and later

- Fix race condition

Version 0.9.15 45.6 KB Works with Firefox 26.0a1 and later

- Support for new download API

Version 0.9.14 231.0 KB Works with Firefox 15.0 and later

- show 'Downloads'-window integration in Firefox > 19.* if old Download-UI is enabled

Version 0.9.13 230.8 KB Works with Firefox 15.0 and later

- preferences for 'Downloads'-window integration are hidden in Firefox > 19.*
- set permission for private mode

Version 0.9.12 230.3 KB Works with Firefox 15.0 and later

- updated to Add-on SDK 1.14
- workaround for utf-8 encoding error in sdk/window/utils -> open
- fixed umlauts in German translation
- added missing translations for command preview in preferences
- only shows predefined commands for the current platform

Version 0.9.11 227.1 KB Works with Firefox 18.0 and later

Version 0.9.10 227.0 KB Works with Firefox 18.0 and later

- Updated to Add-on SDK 1.13.2
- Fix for DTA 3.0b
- Added logout command for Windows to predefined commands
- Fixed predefined suspend and hibernate commands for Windows
- added german translation

Version 0.9.9 195.4 KB Works with Firefox 15.0 and later

- changed background color of dialogs
- removed windows logout command
- added -f argument to windows commands
- added predefined commands for Mac OS X

Version 0.9.8 195.3 KB Works with Firefox 15.0 and later

- Updated to Add-on SDK 1.10
- Workaround for Bug 796857

Version 0.9.7 192.5 KB Works with Firefox 14.0 and later

Updated to Add-on SDK 1.9

Version 0.9.6 190.5 KB Works with Firefox 10.0 and later

Updated to Add-on SDK 1.6

Version 0.9.5 181.2 KB Works with Firefox 10.0 and later

Updated to Add-on SDK 1.5

Version 0.9.4 207.9 KB Works with Firefox 9.0 and later

Recovers data from Add-on-SDK 1.4 - 1.4.2

Version 0.9.3 200.7 KB Works with Firefox 9.0 and later

Updated to Add-on-SDK 1.4.3

Version 0.9.2 200.7 KB Works with Firefox 9.0 and later

Compatibility with Firefox 10.*

Version 0.9 207.9 KB Works with Firefox 7.0 and later

Compatibility with Firefox 8.*

Version 0.8 205.8 KB Works with Firefox 4.0b7 and later

* Updated to Add-on SDK 1.1
* Fixed Preferences link

Version 0.7.2 199.7 KB Works with Firefox 4.0b7 and later

Version 0.7.sdk.1.0 281.6 KB Works with Firefox 4.0b7 and later

Version 0.7 297.0 KB Works with Firefox 4.0b7 and later

* integration into Firefox and DownThamAll! is now configurable
* minor improvements

Version 0.5 284.7 KB Works with Firefox 4.0b7 and later

limited window size of error message dialogs

Version 0.3 252.9 KB Works with Firefox 4.0b7 and later

replaced innerHTML with textContent