It is/not compatible Rated 5 out of 5 stars

Great add-on but a funny thing. I run the identical FF (9.0.1) on my PC and my Lap top. Is great on the laptop but shows as not compatible on the PC. Odd

This review is for a previous version of the add-on (2008.12.15). 

Thanks for your feedback Mal. To install this add-on you must be online. Firefox has to be able to communicate with the Mozilla servers to check the compatibility of the add-on before it will override the compatibility coded in the add-on and continue with the install. For more information visit