Awesome Rated 5 out of 5 stars

I just installed it last week and loved it but today i upgraded to FF3.0 and it is not compatible with it :( hope there will one for it soon.