I want it! Rated 1 out of 5 stars

Why can't I download it? I have the most recent version of FF (2.0.0.13)?

This review is for a previous version of the add-on (0.1.2). 

Requires Firefox 3 (not yet released)

Darkeforce, AnyColor requires Firefox 3 which hasn\'t been released yet (it\'s in beta). This is why the site tells you that you need to have a newer version.