Rated 3 out of 5 stars

This does not work with 3.6 beta 5.. it completely fubars Firefox. Needs an update.

This review is for a previous version of the add-on (0.7.10).