Doesn't works with FF 2.0 Rated 5 out of 5 stars

Can someone please update this. Because as soon as I upgraded with FF 20.0 the toolbar has stopped working.

This review is for a previous version of the add-on (1.7.1.1-signed). 

Updated for Firefox 20!

Keral, Sparky 1.8.0 is compatible with Firefox 20. Find a pre-release version here: https://s3.amazonaws.com/com.alexa.toolbar/sparky-1.8.0.xpi

Very useful indeed Rated 5 out of 5 stars

Very useful indeed. I have it installed on all PCs of mine. It allows me to have an approximate idea about the traffic that the site gets.

This review is for a previous version of the add-on (1.7.0.1-signed).