1.1 with FF 4b4? Rated 3 out of 5 stars

I get an error if I want to install your older version Version 1.1 3.09.2010 in my Firefox 4 Beta 6. But this version is compatible with your information of version 1.1. Isn't it?

This review is for a previous version of the add-on (1.2).