Rated 5 out of 5 stars

Works for my FF 3.0.7

This review is for a previous version of the add-on (1.7).