ACR 1.0.1 incompatible? with latest Firefox 10 & 11 & 12 for Windows Rated 3 out of 5 stars

Same incombatibility as user "aides" reports:
in "Add-on Compatibility Reporter 1.0.1" for Nightly 11.0a1 and Aurora 10.0a2, although the add-ons incompatible at the installation of Add-on Compatibility Reporter 1.0 were activated, if it updates to 1.0.1, they were deactivated compulsorily, without a possibility to reactivation.
Because of this I stepped back to version 1.0 and will stay there till an improvement.
"Add-on Compatibility Reporter 1.0.1" works still in Firefox 3.6.xx, 8.0 and 9.0b5.
Me too would like to ask for an improvement as soon as possible, and please add a feature to switch/unswitsh the compatibility-test - till now you can only switch on the compatibility-test but there's no way to switch it off again, except the bothering use of about:config.
Additional belated note: now I realized that the most add-ons are reactivated again (with newly installed ACR 1.0.1) presumably because the developers marked them as compatible and Firefox checks this when you are online. Only the add-on "RealPlayer Browser Record Plugin 15.00" remains deactivated.
Therefore now 1 point because you cannot switch/unswitch the comptbility-test.
Review-update on Dec 23, 2011 for ACR 1.0.2:
With the update 1.0.2 ACR works properly now with Firefox 10 to 12 - but still missing a key to switch/UNSWITCH the comptbility-test.

This review is for a previous version of the add-on (1.0.1). 

This sounds like a bug somewhere, either in ACR or Firefox. We are resetting compatibility prefs back to default in builds that have the new 'Compatible by Default' feature. This is because the two features do not play nice together. However, if 'Compatible by Default', I imagine add-ons that are not compatible should not be disabled.