Rated 1 out of 5 stars

Well, this just sucks. I just did the update to 4.0b.8 and now, though it says it's compatible in the description, I get the "this cannot be installed because it's not compatible" message. Add to that the fact that ALL of my addons have been marked as incompatible and yet, they all still work, and I'm wondering if Mozilla is paying attention.

This review is for a previous version of the add-on (0.7.1-signed.1-signed).