Rated 5 out of 5 stars

The developer version of the Add-ons Compatibility Reporter version 0.4.3 works with Firefox 3.5 - 3.7a6pre and is here: http://quality.mozilla.org/events/2010/testday-new-add-ons-manager/ or you can download it from this link: https://bugzilla.mozilla.org/attachment.cgi?id=448362

This review is for a previous version of the add-on (0.4.2).