No support for Firefox 3.6.15 at the moment Rated 5 out of 5 stars

At the moment this add-on does not support the latest stable Firefox (3.6.15), but it should support current stable release (Firefox 3.6.15)

This review is for a previous version of the add-on (0.0.19.1-signed.1-signed).