Rated 4 out of 5 stars

Corrupt file -cannot install -message from Firefox

pls fix, used on other PC's
its good

This review is for a previous version of the add-on (3.5.20090708).