Icon of AdBlocker Lite

AdBlocker Lite 0.4.0 Compatible with Firefox 57+

by AdblockLite

block ads seamlessly on popular websites