For firefox 57+ Rated 3 out of 5 stars

It doesn't work for firefox 57+, you have to install the new addon which uses web extensions https://addons.mozilla.org/fr/firefox/addon/adblock-for-firefox/

This review is for a previous version of the add-on (2.9.1).