Rated 5 out of 5 stars

Time & confusion saver extension :-)
I'm glad that ActiveInbox 4.0.2.20 works perfectly into Firefox 5.0 (it is available from thier website as quoted in the description).