Please remove the version limitation Rated 4 out of 5 stars

Addon is not possible to install to Firefox 12+. Please can you remove the version limitation? The current numbering scheme with firefox is running too fast to match with the addon updates.