Incompatible with Firefox 3.6.6 Rated 3 out of 5 stars

I tried installing the script but add-on but it was not compatible with the latest Firefox version. Could we have an update please? I think this is important since many users automatically update their browser to the latest version.