Rated 5 out of 5 stars

It works good with FF 3.0
I have change a little bit in the XPI file and now i can install it on FF 3.0.

I upload it to here for everyone who have FF 3.0 and wanna have it :)

This review is for a previous version of the add-on (1.2.8).