Fails to work with FFx 3.5.2 Rated 5 out of 5 stars

The Version 1.3.2.1 states that it Works with FFx up to 3.6a1pre. HOWEVER -- Fails to work with FFx Ver 3.5.2 as at 24 Aug 2009 2115h CST. It must be something quite minor... hope there will be a fix soon.... it's a great little extension.