Rated 5 out of 5 stars

Still works fine with Firefox 7 if you have the Add-on Compatibility Reporter add-on installed.

Rated 5 out of 5 stars

Aardvark seems to work just fine in Firefox 4.0 as long as you use the Add-on Compatibility Reporter add-on.