Rated 5 out of 5 stars

Still works fine with Firefox 7 if you have the Add-on Compatibility Reporter add-on installed.

This user has a previous review of this add-on.