Missing Rated 5 out of 5 stars

I am still around, but I don't release this addon anymore. At some point in the past, my version was deleted from my Rapid Share account AND my account was deleted as well. I can only assume this was done at the request of The Weather Channel. I have contacted them on multiple occasions to request being allowed to continue this project and have never received ANY reply. So far now, I still fix it for myself, but since there is no safe place to release it, that is all I do.

As for not working, I am currently running Firefox 20.0 and just did an uninstall and re-install of this addon (1.1.9.5) without any issues.

Good Luck all!

SilverHawk

Rated 5 out of 5 stars

You cannot use the version found here on any version of Firefox greater than 3.x.
They made changes to the way extensions are handled in 4.x and again in 5.x.
I have modified the addon to work with versions 4.x and above and I have it available for download here:

My Release - Fixed for 4.x & above (NEW LINK) This is the ONLY place I release my version.
https://rapidshare.com/files/3486516993/1-clickweather-1.1.9.5-fx.xpi

To install it:
1) Download the archive from the link above.
2) Remove the existing addon from Firefox and restart Firefox.
3) Click Tools->Addons
4) Click the down arrow next to the gear icon and click Install Add-on From File.
3) Browse to where you downloaded it to, select the archive and let it install.

Now, If you don't trust my code that's fine. If you read through all of my reviews here I describe exactly what
changes were made to get it to work. You can download the version here and make those changes manually to get
it to work with FF 4.x and above. I simply provide the modified archive for those who are not technically inclined.

This version has been tested on version 12 of Firefox and Waterfox (Windows) and works without issue.

Changes:
Un-archived the original Java jar file. No, I did not want to do that, it just makes it easier to modify the program in the future.
install.rdf - Bumped the minimum version to 4.0
install.rdf - Bumped the maximum version to 30.x (probably no longer needed, but what the heck).
chrome/config/appconfig.xml & appconfig_default.xml
Changed line 738-767 in both files to fix where the menu links point to. One caveat though; Weather.com changed their system recently
and some of the old links no longer work. For example, you can only go out 1 day,5 days or 10 days in extended forecast. I have fixed
the links to reflect this as best I could...sorry, don't blame me.

MD5 Checksum: b4da7466fc4e07384103d33d9d4c46d9

Silverhawk

New Download Location Rated 5 out of 5 stars

You cannot use the version found here on any version of Firefox greater than 3.x.
They made changes to the way extensions are handled in 4.x and again in 5.x.
I have modified the addon to work with versions 4.x and above and I have it available for download here:

My Release - Fixed for 4.x & above (NEW LINK) This is the ONLY place I release my version.
https://rapidshare.com/files/2557435918/1-clickweather-1.1.9.4-fx.xpi

To install it:
1) Download the archive from the link above.
2) Remove the existing addon from Firefox and restart Firefox.
3) Click on File->Open and browse to where you downloaded it to.
4) Select the archive and let it install.

Now, If you don't trust my code that's fine. If you read through all of my reviews here I describe exactly what
changes were made to get it to work. You can download the version here and make those changes manually to get
it to work with FF 4.x and above. I simply provide the modified archive for those who are not technically inclined.

This version has been tested on 10 & 11 as well and works without issue.

Changes:
Just a new download location

MD5 Checksum: 1c9a3db9d149f18fb24a30064c37b6d4

Silverhawk

Rated 5 out of 5 stars

You cannot use the version found here on any version of Firefox greater than 3.x.
They made changes to the way extensions are handled in 4.x and again in 5.x.
I have modified the addon to work with versions 4.x and above and I have it available for download here:

My Release - Fixed for 4.x & above (NEW LINK) This is the ONLY place I release my version.
http://www.wupload.com/file/2650866027/1-clickweather-1.1.9.4-fx.xpi

To install it:
1) Download the archive from the link above.
2) Remove the existing addon from Firefox and restart Firefox.
3) Click on File->Open and browse to where you downloaded it to.
4) Select the archive and let it install.

Now, If you don't trust my code that's fine. If you read through all of my reviews here I describe exactly what
changes were made to get it to work. You can download the version here and make those changes manually to get
it to work with FF 4.x and above. I simply provide the modified archive for those who are not technically inclined.

This version has been tested on 10 & 11 as well and works without issue.

This is a new link that I have modified slightly:

File modified: install.rdf
1) Bumped up the revision number to 1.1.9.4.
2) Modified install.rdf with new revision number and allowing it to install on Firefox up to version 12.
MD5 Checksum: 1c9a3db9d149f18fb24a30064c37b6d4

Silverhawk

Rated 5 out of 5 stars

You cannot use the version found here on any version of Firefox greater than 3.x.
They made changes to the way extensions are handled in 4.x and again in 5.x.
I have modified the addon to work with versions 4.x and above. I have it available for download here:

My Release - Fixed for 4.x & above (NEW LINK) This is the ONLY place I release my version.
http://www.wupload.com/file/2650866027/1-clickweather-1.1.9.4-fx.xpi

To install it:
1) Download the archive from the link above.
2) Remove the existing addon from Firefox and restart Firefox.
3) Click on File->Open and browse to where you downloaded it to.
4) Select the archive and let it install.

Now, If you don't trust my code that's fine. If you read through all of my reviews here I describe exactly what
changes were made to get it to work. You can download the version here and make those changes manually to get
it to work with FF 4.x and above. I simply provide the modified archive for those who are not technically inclined.

This is a new link that I have modified slightly:

File modified: install.rdf
1) Bumped up the revision number to 1.1.9.4.
2) Modified install.rdf with new revision number and allowing it to install on Firefox up to version 12.
MD5 Checksum: 1c9a3db9d149f18fb24a30064c37b6d4

Silverhawk

Archive Moved Again Rated 5 out of 5 stars

Ok. Looks like Fileserve has changed to only allow files you own to be downloaded. So here is the
new file location. This is getting to be tedious.

http://www.wupload.com/file/2650866027/1-clickweather-1.1.9.4-fx.xpi

SilverHawk

Moved Archive Rated 5 out of 5 stars

Well, in light of today's shutdown of Megaupload, I have moved the archive to FileServe.

http://www.fileserve.com/file/FBMRvyq/1-clickweather-1.1.9.4-fx.xpi

MD5 Checksum: 1c9a3db9d149f18fb24a30064c37b6d4

Thanks All Rated 5 out of 5 stars

A big you're welcome to all of you. I use this add-on as well and I know most people are not technically inclined so that is why I fix and release it.

This extension is not open source so I cannot just fork it and build my own from it, but I have sent emails to TWC asking for permission to continue to develop it. I don't even want paid for it or anything. So far, my emails have been greeted with silence. I am still hopeful though.

So, for now, I'll try to continue to fix any issues, but BE WARNED - there could come a day when it stops working and it won't be able to be fixed.

Enjoy!

Silverhawk

My Release - Fixed for 4.x & above ( NEW LINK ) This is the ONLY place I release my version.
http://www.megaupload.com/?d=TCUGTUXT

New Update Rated 5 out of 5 stars

You cannot use the version found here on any version of Firefox greater than 3.x.
They made changes to the way extensions are handled in 4.x and again in 5.x.
I have modified the addon to work with versions 4.x and above. I have it available for download here:

My Release - Fixed for 4.x & above ( NEW LINK ) This is the ONLY place I release my version.
http://www.megaupload.com/?d=TCUGTUXT

To install it:
1) Download the archive from the link above.
2) Remove the existing addon from Firefox and restart Firefox.
3) Click on File->Open and browse to where you downloaded it to.
4) Select the archive and let it install.

Now, If you don't trust my code that's fine. If you read through all of my reviews here I describe exactly what
changes were made to get it to work. You can download the version here and make those changes manually to get
it to work with FF 4.x and above. I simply provide the modified archive for those who are not technically inclined.

This is a new link that I have modified slightly:

File modified: install.rdf
1) Bumped up the revision number to 1.1.9.4.
2) Modified install.rdf with new revision number and allowing it to install on Firefox up to version 12.
MD5 Checksum: 1c9a3db9d149f18fb24a30064c37b6d4

Silverhawk

1 ClickWeather Updated Rated 5 out of 5 stars

You cannot use the version found here on any version of Firefox greater than 3.x. They made changes to the way extensions are handled in 4.x and again in 5.x. I have modified the addon to work with versions 4.x and above. I have it available for download here:
My Release - Fixed for 4.x & above ( NEW LINK ) This is the ONLY place I release my version.
http://www.megaupload.com/?d=XON52IR8
To install it:
1) Download the archive from the link above.
2) Remove the existing addon from Firefox and restart Firefox.
3) Click on File->Open and browse to where you downloaded it to.
4) Select the archive and let it install.

Now, If you don't trust my code that's fine. If you read through all of my reviews here I describe exactly what changes were made to get it to work. You can download the version here and make those changes manually to get it to work with FF 4.x and above. I simply provide the modified archive for those who are not technically inclined.

Also..it seems to work fine with 8.x and 9.x.

This is a new link that I have modified slightly:

File modified: install.rdf
1) Bumped up the revision number.
2) Modified install.rdf with new revision number and allowing it to install on Firefox up to version 9.

Silverhawk

1 ClickWeather Updated Rated 5 out of 5 stars

Haven't reposted this in awhile so:

You cannot use the version found here on any version of Firefox greater than 3.x. They made changes to the way extensions are handled in 4.x and again in 5.x. I have modified the addon to work with versions 4.x and above. I have it available for download here: My Release - Fixed for 4.x & above
( NEW LINK )
http://www.megaupload.com/?d=XON52IR8
To install it:
1) Download the archive from the link above.
2) Remove the existing addon from Firefox and restart Firefox.
3) Click on File->Open and browse to where you downloaded it to.
4) Select the archive and let it install.

Now, If you don't trust my code that's fine. If you read through all of my reviews here I describe exactly what changes were made to get it to work. You can download the version here and make those changes manually to get it to work with FF 4.x and above. I simply provide the modified archive for those who are not technically inclined.

Also..it seems to work fine with 8.x.

This is a new link that I have modified slightly:

File modified: install.rdf
1) Bumped up the revision number.
2) Modified install.rdf with new revision number and allowing it to install on Firefox up to version 9.

*WARNING* I do not have a Firefox 9 install so I cannot test it! Please post any issues you may have and
I will see if I can fix it.


Silverhawk

Repost Rated 5 out of 5 stars

Haven't reposted this in awhile so:

You cannot use the version found here on any version of Firefox greater than 3.x. They made changes to the way extensions are handled in 4.x and again in 5.x. I have modified the addon to work with versions 4.x and above. I have it available for download here: My Release - Fixed for 4.x & above
http://www.megaupload.com/?d=HWX605SS
To install it:
1) Download the archive from the link above.
2) Remove the existing addon from Firefox and restart Firefox.
3) Click on File->Open and browse to where you downloaded it to.
4) Select the archive and let it install.

Now, If you don't trust my code that's fine. If you read through all of my reviews here I describe exactly what changes were made to get it to work. You can download the version here and make those changes manually to get it to work with FF 4.x and above
I simply provide the modified archive for those who are not technically inclined.

Also..it seems to work fine with 7.x and the current nightly build as well.

Silverhawk

Rated 5 out of 5 stars

I am glad everyone is finding this useful.

Repost:

You cannot use the version found here on any version of Firefox greater than 3.x. They made changes to the way extensions are handled in 4.x and again in 5.x. I have modified the addon to work with versions 4.x and above. I have it available for download here: My Release - Fixed for 4.x & above
http://www.megaupload.com/?d=HWX605SS
To install it:
1) Download the archive from the link above.
2) Remove the existing addon from Firefox and restart Firefox.
3) Click on File->Open and browse to where you downloaded it to.
4) Select the archive and let it install.

Now, If you don't trust my code that's fine. If you read through all of my reviews here I describe exactly what changes were made to get it to work. You can download the version here and make those changes manually to get it to work with FF 4.x and above
I simply provide the modified archive for those who are not technically inclined.

Also..it seems to work fine with 6.x and the current nightly build as well.

Silverhawk

Rated 5 out of 5 stars

Since my last link has been moved down quite a bit, I am re-posting it here:

You cannot use the version found here on any version of Firefox greater than 3.x. They made changes to the way extensions are handled in 4.x and again in 5.x. I have modified the addon to work with both versions and have it available for download here: My Release - Fixed for 4.x & 5.x
http://www.megaupload.com/?d=HWX605SS
To install it:
1) Download the archive from the link above.
2) Remove the existing addon from Firefox and restart Firefox.
3) Click on File->Open and browse to where you downloaded it to.
4) Select the archive and let it install.

Now, If you don't trust my code that's fine. If you read through all of my reviews here I describe exactly what changes were made to get it to work. You can download the version here and make those changes manually to get it to work with FF 4.x & 5.x
I simply provide the modified archive for those who are not technically inclined.

Silverhawk

Rated 5 out of 5 stars

Glad most people are finding this useful.

@BudMan, I am not really familiar with BSD (more a Linux guy) Did you download a copy from the link I provided? If not and you downloaded it off of here it definitely will not work. That error message is usually caused by the .xpi file not getting unpacked. Try following these steps:
1) Download from http://www.megaupload.com/?d=HWX605SS
2) Remove your existing copy of 1 Click Weather from Firefox and restart it.
3) Click on File->Open File and select the version you downloaded from above.
4) Install it and enjoy!
If that doesn't work, then you'll have to look in the .mozilla directory in your home directory and see if it unpacked it or not. If it didn't you should just be able to unpack the .xpi file (just a zip file) manually into a subdirectory and restart Firefox.

@ononoma Not sure why you're having an issue with MU. I have never had any issues with them, which is why I have it hosted there. Have you tried using a download manager such as JDownloader?

SilverHawk

Rated 5 out of 5 stars

@Gary: Yes, if you click on my name and read all of my reviews, it tells you how to fix it for 4.x and 5.x. The 5.x fix also has to include the 4.x fix as well. You would think they would make the changes, but haven't updated this addon in a LONG time.

Like I said, I fix it because I use it and I release the modified file to anyone else who wants to use it. If you don't trust the code I put on megaupload, which is the ONLY place I have released my changes, you can always download the version here, read my reviews and manually make the changes yourself.
My Release - Fixed for 4.x & 5.x
http://www.megaupload.com/?d=HWX605SS

Enjoy!

SilverHawk

Rated 5 out of 5 stars

@Sander Lepik - I am not sure if you're directing your comments at me or not, but I didn't create this addon. Since TWC appears to have forgotten about it, I have been trying to fix it when new versions of Firefox come out since I use it myself. You cannot use the version here on Firefox greater than 3.x, it will not work due to changes in the way addons are handled. You must download it from this link for versions greater the 4.x:

http://www.megaupload.com/?d=HWX605SS

If you don't trust that code, that's fine because in my previous "reviews" I describe how to fix it manually. I also use this on Linux so I know it works.

SilverHawk

Fixed for Firefox 5+ Rated 5 out of 5 stars

Modified the install.rdf to work on versions up to 8.*
Incremented the version to 1.1.9.2
I had to modify one of the Javascript files in the .jar file. Sorry, but there's no way around it as a Javascript error
was making it fail.
chrome/1clickweather.jar/content/1clickweather/js/1clickweather.js
Line 452-454 in the function parameters they used class as a variable name.
class is a reserved keyword and cannot be used. I changed it to Myclass which allows it to work.
Original File
function create_class(class) {
return new Function('return new ' + class)();
};
Modified File
function create_class(Myclass) {
return new Function('return new ' + Myclass)();
};

Link to fixed file:
http://www.megaupload.com/?d=HWX605SS

Remove your existing version then go to File->File Open to load this modified version.
Enjoy!
SilverHawk

Rated 5 out of 5 stars

Hmmm..looks like my link to the fixed archive keeps getting removed for some reason. Anyways here it is again:

http://www.megaupload.com/?d=W1HDG9HM

Remember, be careful about downloading random files off the internet!

SilverHawk

Rated 5 out of 5 stars

@Roving - Remove your existing weather extension, RESTART firefox and then try to install the modified version.