working again Rated 4 out of 5 stars

Thanks, Bill - saw the change you made - I think since FF has development versions out to ~17 (based on bugs I have filed with Bugzilla), I'm wondering if the max-version parameter can be pushed out that far?

This user has 3 previous reviews of this add-on.