Needs updating for FF12 and beyond Rated 3 out of 5 stars

FYI for silverhawk - looks like changes to version 12 have rendered your add-on broken again. It is still a great add-on - it's just a matter of keeping up with Firefox's changes.

This user has other reviews of this add-on.