Rated 1 out of 5 stars

It doesn't work since FF4. Just generates cryptic error messages. Despite the long development period for FF4, they waited to update and then didn't get it right. Now it just generates error messages. Get Forecastfox instead.

This user has other reviews of this add-on.