Please update for Firefox 6.0 Rated 5 out of 5 stars

Unfortunately this super add doesn't work anymore since Firefox 3.6...
I really miss it,
so I pass by every one or two monthes on this page, to see if anything's new...
Still not... (:-
It would be fantastic if you could update it for Firefox 6.0
Very usefull for anyone who makes a lot of research on Internet...
Hope you'll think about, if not too much work for adapting this add for Firefox 6.0...
Best regards from Geneva, Switzerland :-)