Adblock Plus Version History

81 versions

Be careful with old versions!

These versions are displayed for reference and testing purposes. You should always use the latest version of an add-on.

Version 0.7.5.2 233.5 kB Works with Firefox 1.5 - 3.0a8, SeaMonkey 1.0 - 2.0a1, Thunderbird 1.5 - 3.0a1

IMPORTANT: If you use any of the following extensions, you will need to update them as well: Element Hiding Helper, Adblock Plus Filter Uploader, Adblock Filterset.G Updater, backword

Compatible with: Firefox 1.5, Thunderbird 1.5, SeaMonkey 1.0, Flock 0.5, K-Meleon 1.02 (see http://adblockplus.org/en/kmeleon for installation instructions), Songbird 0.2 - and higher. Note: It is recommended to use at least Firefox 2.0, Thunderbird 2.0, SeaMonkey 1.1, K-Meleon 1.1 or Songbird 0.2, support for older versions will likely be dropped in a few months.
Included locales: en-US, ar, ca-AD, cs-CZ, da-DK, de-DE, el-GR, en-GB, es-ES, et-EE, fa-IR, fi-FI, fr-FR, fy-NL, hr-HR, hu-HU, it-IT, ja-JP, ko-KR, lt-LT, mn-MN, nb-NO, nl-NL, pl-PL, pt-BR, pt-PT, ro-RO, ru-RU, sk-SK, sl-SI, sv-SE, th-TH, tr-TR, uk-UA, vi-VN, zh-CN, zh-TW

Detailed changelog: http://adblockplus.org/en/changelog-0.7.5.2
Single-language builds: http://adblockplus.org/en/installation#single_language
K-Meleon builds: http://adblockplus.org/en/kmeleon
FAQ: http://adblockplus.org/en/faq

Version 0.7.5.1 234.5 kB Works with Firefox 1.5 - 3.0a8, SeaMonkey 1.0 - 2.0a1, Thunderbird 1.5 - 3.0a1

Compatible with: Firefox 1.5, Thunderbird 1.5, SeaMonkey 1.0, Flock 0.5, K-Meleon 1.02 (see http://adblockplus.org/en/kmeleon for installation instructions), Songbird 0.2 - and higher. Note: It is recommended to use at least Firefox 2.0, Thunderbird 2.0, SeaMonkey 1.1, K-Meleon 1.1 or Songbird 0.2, support for older versions will likely be dropped in a few months.
Included locales: en-US, ar, ca-AD, cs-CZ, da-DK, de-DE, el-GR, en-GB, es-ES, et-EE, fa-IR, fi-FI, fr-FR, fy-NL, hr-HR, hu-HU, it-IT, ja-JP, ko-KR, lt-LT, mn-MN, nb-NO, nl-NL, pl-PL, pt-BR, pt-PT, ro-RO, ru-RU, sk-SK, sl-SI, sv-SE, th-TH, tr-TR, uk-UA, vi-VN, zh-CN, zh-TW

Detailed changelog: http://adblockplus.org/en/changelog-0.7.5.1
Single-language builds: http://adblockplus.org/en/installation#single_language
K-Meleon builds: http://adblockplus.org/en/kmeleon
FAQ: http://adblockplus.org/en/faq

Version 0.7.5 227.3 kB Works with Firefox 1.5 - 3.0a5, SeaMonkey 1.0 - 1.5a, Thunderbird 1.5 - 3.0a1

Version 0.7.2.4 221.2 kB Works with Firefox 1.5 - 3.0a4, SeaMonkey 1.0 - 1.5a, Thunderbird 1.5 - 3.0a1

Version 0.7.2.3 220.2 kB Works with Firefox 1.5 - 3.0a2, SeaMonkey 1.0 - 1.0, Thunderbird 1.5 - 3.0a1

Version 0.7.2.2 216.1 kB Works with Firefox 1.5 - 3.0a1, SeaMonkey 1.0 - 1.0, Thunderbird 1.5 - 3.0a1

Version 0.7.2.1 216.1 kB Works with Firefox 1.5 - 3.0a1, SeaMonkey 1.0 - 1.0, Thunderbird 1.5 - 3.0a1

Version 0.7.2 216.1 kB Works with Firefox 1.5 - 3.0a1, SeaMonkey 1.0 - 1.0, Thunderbird 1.5 - 3.0a1

Version 0.7.1.2 203.8 kB Works with Firefox 1.5 - 3.0a1, SeaMonkey 1.0 - 1.0

Version 0.7.1.1 185.3 kB Works with Firefox 1.5 - 3.0a1, SeaMonkey 1.0 - 1.0

Version 0.7.1 185.3 kB Works with Firefox 1.5 - 2.0a3, SeaMonkey 1.0 - 1.0

Version 0.7.0.2 166.9 kB Works with Firefox 1.5 - 1.0+

Version 0.7.0.1 160.8 kB Works with Firefox 1.5 - 1.0+

Version 0.7 154.6 kB Works with Firefox 1.5 - 1.0+

Version 0.6.1.2 112.6 kB Works with Firefox 1.5 - 1.0+

Version 0.6.1.1 101.4 kB Works with Firefox 1.5 - 1.0+

Version 0.6.1 88.1 kB Works with Firefox 1.5 - 1.0+

Version 0.6.0.4 38.9 kB Works with Firefox 1.5 - 1.0+

Check out http://adblockplus.org/en/changelog-0.6.0.4 for a detailed changelog.

Version 0.6.0.3 28.7 kB Works with Firefox 0.7 - 1.5.0.*

Check out http://adblockplus.org/en/changelog-0.6.0.3 for a detailed changelog.

Version 0.6.0.2 27.6 kB Works with Firefox 0.7 - 1.5.0.*

Check out http://adblockplus.org/en/changelog-0.6.0.2 for a detailed changelog.

Version 0.6 25.6 kB Works with Firefox 0.7 - 1.5.0.*

This version won't overwrite Adblock or Adblock Plus 0.5. If you have one of these extensions installed, you should uninstall it first.