Bewertet mit 5 von 5 Sternen

Beta 1.0.7 of this works in FF 3.6 so use that?