Needs Firefox 19 update Bewertet mit 5 von 5 Sternen

Great program but needs to be updated to FF19. Mozilla should stop these constant updates. It is killing add-ons. I still give it 5 stars. After all it is hardly the developer's fault that mozilla now has this stupid policy.

Dear mig, please update it ASAP. I can't live without this add-on.

Diese Bewertung wurde für eine vorherige Version des Add-ons ( abgegeben. 

Can you give a try with this beta version and report if it fixes the problem in the bugzilla interface