Bewertet mit 3 von 5 Sternen

won't install on FF 3.6

Diese Bewertung wurde für eine vorherige Version des Add-ons (2.024) abgegeben.