Bewertet mit 5 von 5 Sternen

I would like to fix this extension to support new versions of Firefox. Please contact me