Need update for FF 3.6 and 3.7 Bewertet mit 5 von 5 Sternen

This is a great idea and looks like a wonderful implementation. Unfortunately, it doesn't work with Firefox 3.6.x on Ubuntu.

Any chance of getting an update?