Bewertet mit 3 von 5 Sternen

Incompatible with Firefox 18 on linux 64bit
Update: I download from lastpass.com and it worked. Don't know why~, But it surely is a great addon.

Diese Bewertung wurde für eine vorherige Version des Add-ons (2.0.0) abgegeben.