Bewertet mit 5 von 5 Sternen

LastPass 2.0.0 is incompatible with Firefox 17.0.1.

Lastpass 20.0a1 (https://lastpass.com/lp.php) works great, thanks :)

Diese Bewertung wurde für eine vorherige Version des Add-ons (2.0.0) abgegeben. 

LastPass works with all Firefox versions

We should work with the latest (20.0a1) version of Firefox. Please download from https://lastpass.com/lp.php.

Thanks