It won't work for me Bewertet mit 1 von 5 Sternen

Every single time I try to use this add-on, all I receive is a page telling me that it can't translate because some part of the process was from an SSL unprotected site and the translation site is protected. I don't understand the problem. I don't want to need to understand the problem. I just want it to work like my old Google translation used to work. I've pretty much given up on any non-English websites, sadly, for this reason. Google's became problematic and this one is, and I don't have the time to spend doing geek problem-solving. I want the geeks to do it in advance. That's what makes cyber-geeks valuable to the rest of us.