Incompatible with Firefox 14.0.1? Bewertet mit 1 von 5 Sternen

This add-on does not seem to be compatible with firefox version 14.0.1. Can anyone confirm that?

Diese Bewertung wurde für eine vorherige Version des Add-ons (0.9.2) abgegeben.