Bewertet mit 4 von 5 Sternen

Please update it to Firefox 3.7 build. It works well in 3.7 branch.

Diese Bewertung wurde für eine vorherige Version des Add-ons (2.6) abgegeben.